Start a new topic

Termometry cyfrowe DS18B20

W swojej instalacji mam około 10 termometrów DS18B20 i praktycznie zawsze odczyt któregoś z nich to "nil"... Czy problem tkwi w braku rezystora podciągającego? Czy ktoś też tego problemu doświadczył? Czy są może jakieś inne termometry 1-wire lepiej współpracujące z grentonem?


Witam, opisz swoja instalację DS18B20. Jaki przewód, jakie połączenia, jak wyglądają trasy przewodów ( razem czy osobno z energetycznymi ) itd.  

Termometry są ukryte w puszce podtynkowej za włącznikiem. Do podłączenia wykorzystałem 2 żyły skrętki kategorii 5e, która biegnie właśnie do włącznika. Być może na pewnych odcinkach skrętki idą po ścianach, ale problem występuje również w termometrze podłączonym na krótkim odcinku przewodu dwużyłowego podłączonego bezpośrednio do modułu Analog. Oczywiście przewody do termometru są w bezpośrednim sąsiedztwie energetycznych w samej rozdzielni. Nie mam (a może powinienem mieć) rezystor pomiędzy żyłą danych a masą, o którym piszą przy opisie współpracy termometrów z Arduino?

Proszę spróbować wyłączać poszczególne bezpieczniki w rozdzielni elektrycznej. Zostawiając tylko GRENTONA. Mamy właśnie przypadek, że po wyłączeniu jednego z bezpieczników ( przypadkowym ) wszystko wróciło do normy. Problemem okazały się zasilacze do obwodów RGB. Nawet podłączenie ekranów ( do uziemienia ) przy skrętkach tylko pogarszało sytuację. Sytuacja pasowa, szukamy rozwiązania wymiana zasilaczy za 1500 zł raczej nie wchodzi w grę :(

Dziękuję za uwagę. Spróbuję. Czyli podejrzane są transformatory zasilaczy?

Proszę napisać jak lokalizacja problemu. Jestem bardzo ciekawy co u Pana powoduje problem. Może razem uda nam się go rozwiązać.

niestey na tak długotrwałe testy aktualnie nie mam czasu. u mnie wartosc "nil" pojawiala sie nieregularnie i z roznym "nasileniem". zaobserwowalem za to termometr, ktory wydawalo mi sie, ze najczesciej sprawia problem i go odlaczylem. dodalem tez przy samym module Analog regystor 4k7oma i teraz blad pojawia sie znacznie rzadziej ale jednak nadal sie pojawia. czesciej jednak wszystko jest ok. nastepnym krokiem bedzie podlaczenie tego odpietego termometru z powrotem.

Witam

Miałem podobny problem u dwójki klientów.

Mi w instalacji klienta pomogło zwiększenie podpięcia ilości żył ze skrętki np. zamiast 2 żył podłączyłem 2 pary(jeżeli są wolne oczywiście). 

I problem minął.


Pozdrawiam



W temacie czujników DS18B20... zakupiłem u pierwszego sprzedawcy jeden (okazało się, że niesprawny), następnie u drugiego sprzedawcy jeden (działa), później 3 kolejne (nie działa żaden) i u trzeciego sprzedawcy 5 sztuk surowych czujników tj. bez oryginalnych kabelków i gilzy metalowej - żaden nie działa. To daje wynikową cenę ok. 60 zł za jeden sprawny (!). To już taniej bezpośrednio z Grentona kupić :-)


Wszystkie podpinane w identyczny sposób, GND zwarte z Vdd, bez rezystorów. Podpinane pojedynczo przy wyłączonym zasilaniu, na przewodach max 10cm. Tylko jeden bez problemu jest wykrywany przez CLU Discovery. Reszta albo jakby nie istniały, albo OM nie znajduje CLU, albo CLU nie odpowiada na Keep-Alive.


Pytanie do Forumowiczów - czy macie jakiegoś sprawdzonego sprzedawcę? Niech będzie i 10zł za sztukę, ale działającą.

Update / Rozwiązanie:


Na kilkanaście zakupionych DS18B20 okazało się, że tylko jeden działa tak, jak opisuje to Grenton tj. zwarte GND i Vdd czujnika. Cała reszta, którą uznałem za niesprawne zaczęła działać po podłączeniu:

1) +5V na nóżkę Vdd czujnika

2) GND do GND (to dedykowane dla 1W) w module Analog

3) Data do 1W


+5V wziąłem bezpośrednio z kostki ARK dosilającej magistralę co kilka modułów.

Jest stabilnie, wszystkie czujniki są wykrywane i pracują jak należy.


1 person likes this

Ja kupuje na allegro na chybil trafil - albo zaden nie dziala, albo wszystkie dzialaja. Ostatnio zakupilem 20szt od jednego sprzedawcy - zaden nie dzialal. Poszedl zwrot. Wkurzony, gdyz pilnie byly potrzebne zakupilem po 6 szt u 5 sprzedawcow (zwroty allegro smart rulez). Wszystkie 35 szt. dzialaja :P

Zauwazylem tylko jedna wspolna ceche tych niedzialajacych - tak samo jak zamawialem z aliexpres tak i tu sa na cienkich kabelkach i tak jakby koncowka izolacji jest sciagnieta (wisi na koncowce kabelka). Te nie obierane sa ok.

I zeby nie bylo to czujniki sa sprawne wszystkie (w innych urzadzeniach dzialaja - tylko grenton prawdopodobnie ma tak wysrubowane czasy ze te wolniejsze nie dzialaja :)


Czujniki DS18B20 żeby działały sprawnie-stabilnie na dwóch pinach powinny być w trybie potrzymania zasilania na DATA (pomiedzy danymi), możliwe że z tym jest problem w Grenton. Jedne czujniki sobie radzą inne nie :)

Login or Signup to post a comment